IntroductionIntroduction

Wrapping up another year with Craft CMS

We close 2018 with another issue of news, helpful tips, and Craft CMS plugins. Thank you to the creators of the latest batch of links. The Craft community comes through every time. ⭐️

What's of note in this issue? Plugins can now require a version of Craft. Check out the details from Brandon in the Plugged in section for that tip. There is news that Microsoft is losing its Edge (see what I did there?), and there are great Craft tips for all skill levels. Of course, there is another batch of Craft plugins to check out, including a new free first-party plugin to add webhooks to Craft 3.

Thank you to fortrabbit, an official Craft CMS Hosting Partner, for sponsoring this issue. If you've got a Craft site to host, check them out.

If you've got a link to share for an upcoming issue, send it along.

Let's hit the links.

-John Morton

Craft Link List  

News



Featured Sponsor

Tools, tips and fundamentals







Perfecting your technique








Plugged In

Plugin and Craft version requirements

Brandon mentioned an update that should please plugin developers. I'll let him explain.

[We] just pushed an update to Craftnet that prevents the Plugin Store and Updates utility from showing plugins/releases that aren't compatible with the currently-installed Craft version.

That means that it's now possible for you to start releasing plugin updates that require Craft 3.1 (e.g., if you want to start adding project config/environment setting / soft delete/edition support), and only people who are actually running Craft 3.1 will have the option to install at that version or update to it. Just make sure you have this in composer.json:

"require": { "craftcms/cms": "^3.1.0" }

Also of note, as of this change, if your plugin doesn't specify a craftcms/cms requirement, it won't show up in the Plugin Store, or show any available updates anymore.

Craft Link List  










The Craft Advantage


It’s not Craft, but it’s interesting.









Animation on scroll position

Do you want to trigger animation scroll? Some libraries were suggested when the topic came up in Slack recently.

Or, check out the native Intersection Observer method built into many modern browsers.

If you choose to use Intersection Observer, you'll probably want the polyfill since Safari still doesn't support it.

Craft Link List